Elevated API latency

Incident Report for Increase

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 19:55 UTC

Monitoring

API latency has come back down to normal levels now. We will continue to monitor our service health.
Posted Aug 20, 2026 - 16:30 UTC

Identified

We have identified that this issue is related to an incident affecting Google Cloud’s us-west1 region. We are continuing to investigate.
Posted Aug 20, 2026 - 15:58 UTC

Update

We are still observing elevated API latency and are continuing to investigate the issue.
Posted Aug 20, 2026 - 15:47 UTC

Investigating

We are observing elevated API latency and are currently investigating the issue.
Posted Aug 20, 2026 - 15:14 UTC
This incident affected: API.